Pz-LinkCardプラグイン(WordPress) エラーメッセージ(Warning: curl_setopt)が表示される場合はPHPバージョンを5.6以上にすると解決

wpxクラウドにてWordPressブログを運用されている方から、Pz-LinkCardプラグインの「エラーメッセージ」が、記事に表示されているとのご相談がありサポートしました。

対策方法としては、wpxクラウドの管理画面にあるPHPバージョンを5.6以上にすることで解決しました。

エラーメッセージ

エラーメッセージ

Pz-LinkCardプラグインのショートコードを設置した記事にて、以下のようなエラーメッセージが表示されるというものでした。

Warning: curl_setopt(): CURLOPT_FOLLOWLOCATION cannot be activated when an open_basedir is set in /home/〇〇/〇〇/public_html/wp-content/plugins/pz-linkcard/pz-linkcard.php on line 926

原因

WordPressが動作しているwpxクラウドのPHPバージョンが、5.4系統だったことが原因でした。

対策

wpxクラウド管理画面にある「PHPバージョン切り替え」の設定を5.6以上に設定することで解決します。

サーバー管理画面

PHP7を選択すると、WordPressの動作速度が5.6より改善しますが、PHP7の環境で問題を起こす(エラー発生)となるプラグインを利用していないか?テストと確認を行うことが必要となります。

WordPressプラグインについて参考にしている一冊がこちらです。

こんな記事も注目されています。

著者プロフィール

ものくろ(大東 信仁)
ものくろ(大東 信仁)
ブロガー・Web&Blogコーチ。親指シフト orzレイアウト開発者。ブログは月間65万PVを記録(2016年1月)。200回を超えるワークショップ開催・のべ1,000名のブログサポートに携わる。WordPressが得意。

詳しいプロフィールはこちら

もっと
WordPressのこと
について読む